GitHub Advisoryadvisory · Packagist
GHSA-wfm3-gq9h-mrjm Appwrite Directory Traversal vulnerability
HIGH
Official page ↗
- Aliases
- CVE-2022-25377
- Ecosystem
- Packagist
- Packages
- appwrite/server-ce
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- Weaknesses
- CWE-22
- Reviewed
- 2024-02-23
Affected packages
• Packagist appwrite/server-ce: >= 0.5.0, < 0.12.2 → fixed in 0.12.2
Description
The ACME-challenge endpoint in Appwrite 0.5.0 through 0.12.x before 0.12.2 allows remote attackers to read arbitrary local files via ../ directory traversal. In order to be vulnerable, `APP_STORAGE_CERTIFICATES/.well-known/acme-challenge` must exist on disk. (This pathname is automatically created if the user chooses to install Let's Encrypt certificates via Appwrite.)
Related
Alias · CVE (1)
- CVE-2022-25377 The ACME-challenge endpoint in Appwrite 0.5.0 through 0.12.x before 0.12.2 allows remote attackers to read arbitrary local files via ../… vulnerability
Weakness · CWE (1)
- CWE-22 Improper Limitation of a Pathname to a Restricted Directory weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2022-25377 advisory
- https://github.com/appwrite/appwrite/pull/2780 web
- https://github.com/appwrite/appwrite/commit/892f6fa4ba0d44e2435ffad1a84542400cfb7a9b web
- https://dubell.io/unauthenticated-lfi-in-appwrite-0.5.0-0.12.1 web
- https://github.com/appwrite/appwrite package
- https://github.com/appwrite/appwrite/blob/0.12.0/app/controllers/general.php#L539 web
- https://github.com/appwrite/appwrite/releases/tag/0.12.2 web