GitHub Advisoryadvisory · Packagist
GHSA-wg25-j79r-v5wp Magento Cross-Site Scripting via Signifyd Guarantee Option Translation Override
MEDIUM
Official page ↗
- Aliases
- CVE-2019-8129
- Ecosystem
- Packagist
- Packages
- magento/community-edition
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2024-05-15
Affected packages
• Packagist magento/community-edition: >= 2.2, < 2.2.10 → fixed in 2.2.10
• Packagist magento/community-edition: >= 2.3, < 2.3.2-p2 → fixed in 2.3.2-p2
Description
A stored cross-site scripting (XSS) vulnerability exists in Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3 or 2.3.2-p1. An authenticated user can exploit it by injecting an embedded expression into a translation.
Related
Alias · CVE (1)
- CVE-2019-8129 A stored cross-site scripting (XSS) vulnerability exists in Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3 or 2.3.2-p1. vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness