GitHub Advisoryadvisory · npm
GHSA-wg96-3933-j2w5 Cross-Site Scripting in sanitize-html
MEDIUM
Official page ↗
- Aliases
- CVE-2017-16017
- Ecosystem
- npm
- Packages
- sanitize-html
- Severity
- Moderate
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2020-06-16
Affected packages
• npm sanitize-html: < 1.2.3 → fixed in 1.2.3
Description
Affected versions of `sanitize-html` are vulnerable to cross-site scripting.
Proof of Concept:
``
produces the following:
``
This is definitely invalid HTML, but would suggest that it's being interpreted incorrectly by the parser.
Recommendation
Update to version 1.2.3 or later.
Related
Alias · CVE (1)
- CVE-2017-16017 sanitize-html is a library for scrubbing html input for malicious values Versions 1.2.2 and below have a cross site scripting vulnerability. vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness