GitHub Advisoryadvisory · Packagist
GHSA-wgpr-9675-8r67 Magento discloses sensitive information via the Multishipping Module
MEDIUM
Official page ↗
- Aliases
- CVE-2021-36038
- Ecosystem
- Packagist
- Packages
- magento/project-community-edition, magento/community-edition
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
- Weaknesses
- CWE-20
- Reviewed
- 2025-11-07
Affected packages
• Packagist magento/project-community-edition: <= 2.0.2 (no fix yet)
• Packagist magento/community-edition: < 2.3.7-p1 → fixed in 2.3.7-p1
• Packagist magento/community-edition: 2.3.7 (no fix yet)
• Packagist magento/community-edition: >= 2.4.2-p1, < 2.4.2-p2 → fixed in 2.4.2-p2
• Packagist magento/community-edition: 2.4.2 (no fix yet)
Description
Magento Commerce versions 2.4.2 (and earlier), 2.4.2-p1 (and earlier) and 2.3.7 (and earlier) are affected by an improper input validation vulnerability in the Multishipping Module. An authenticated attacker could leverage this vulnerability to achieve sensitive information disclosure.
Related
Alias · CVE (1)
- CVE-2021-36038 Magento Commerce versions 2.4.2 (and earlier), 2.4.2-p1 (and earlier) and 2.3.7 (and earlier) are affected by an improper input validation… vulnerability
Weakness · CWE (1)
- CWE-20 Improper Input Validation weakness