GitHub Advisoryadvisory · Packagist
GHSA-wh4m-6rh3-p4rq Magento Open Source allows Improper Input Validation
HIGH
Official page ↗
- Aliases
- CVE-2024-20758
- Ecosystem
- Packagist
- Packages
- magento/community-edition, magento/project-community-edition
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:H
- Weaknesses
- CWE-20
- Reviewed
- 2025-03-04
Affected packages
• Packagist magento/community-edition: 2.4.6 (no fix yet)
• Packagist magento/community-edition: 2.4.5 (no fix yet)
• Packagist magento/community-edition: 2.4.4 (no fix yet)
• Packagist magento/community-edition: >= 2.4.7-beta1, < 2.4.7 → fixed in 2.4.7
• Packagist magento/community-edition: >= 2.4.6-p1, < 2.4.6-p5 → fixed in 2.4.6-p5
• Packagist magento/community-edition: >= 2.4.5-p1, < 2.4.5-p7 → fixed in 2.4.5-p7
• Packagist magento/community-edition: >= 2.4.4-p1, < 2.4.4-p8 → fixed in 2.4.4-p8
• Packagist magento/project-community-edition: <= 2.0.2 (no fix yet)
Description
Adobe Commerce versions 2.4.6-p4, 2.4.5-p6, 2.4.4-p7, 2.4.7-beta3 and earlier are affected by an Improper Input Validation vulnerability that could result in arbitrary code execution in the context of the current user. Exploitation of this issue does not require user interaction, but the attack complexity is high.
Related
Alias · CVE (1)
- CVE-2024-20758 Adobe Commerce versions 2.4.6-p4, 2.4.5-p6, 2.4.4-p7, 2.4.7-beta3 and earlier are affected by an Improper Input Validation vulnerability… vulnerability
Weakness · CWE (1)
- CWE-20 Improper Input Validation weakness