GitHub Advisoryadvisory · npm

GHSA-wh5w-82f3-wrxh CKEditor cross-site scripting vulnerability in AJAX sample

MEDIUM Published 2024-02-07 Modified 2024-02-07 Official page ↗
Aliases
CVE-2023-4771
Ecosystem
npm
Packages
ckeditor4
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weaknesses
CWE-79
Reviewed
2024-02-07

Affected packages

• npm ckeditor4: < 4.24.0-lts → fixed in 4.24.0-lts

Description

Affected packages The vulnerability has been discovered in the AJAX sample available at the `samples/old/ajax.html` file location. All integrators that use that sample in the production code can be affected. Impact A potential vulnerability has been discovered in one of CKEditor's 4 samples that are shipped with production code. The vulnerability allowed to execute JavaScript code by abusing the AJAX sample. It affects all users using the CKEditor 4 at version < 4.24.0-lts where `samples/old/ajax.html` is used in a production environment. Patches The problem has been recognized and patched. The fix will be available in version 4.24.0-lts. For more information Email us at [email protected] if you have any questions or comments about this advisory. Acknowledgements The CKEditor 4 team would like to thank Rafael Pedrero and INCIBE (original report) for recognizing and reporting this vulnerability.

Related

Alias · CVE (1)

  • CVE-2023-4771 A Cross-Site scripting vulnerability has been found in CKSource CKEditor affecting versions 4.15.1 and earlier. vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References