GitHub Advisoryadvisory · npm

GHSA-whpj-8f3w-67p5 vm2 Sandbox Escape vulnerability

CRITICAL Published 2023-05-15 Modified 2023-05-15 Official page ↗
Aliases
CVE-2023-32314
Ecosystem
npm
Packages
vm2
Severity
Critical
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-74
Reviewed
2023-05-15

Affected packages

• npm vm2: < 3.9.18 → fixed in 3.9.18

Description

A sandbox escape vulnerability exists in vm2 for versions up to 3.9.17. It abuses an unexpected creation of a host object based on the specification of `Proxy`. Impact A threat actor can bypass the sandbox protections to gain remote code execution rights on the host running the sandbox. Patches This vulnerability was patched in the release of version `3.9.18` of `vm2`. Workarounds None. References PoC - https://gist.github.com/arkark/e9f5cf5782dec8321095be3e52acf5ac For more information If you have any questions or comments about this advisory: • Open an issue in VM2 Thanks to @arkark (Takeshi Kaneko) of GMO Cybersecurity by Ierae, Inc. for disclosing this vulnerability.

Related

Alias · CVE (1)

  • CVE-2023-32314 vm2 is a sandbox that can run untrusted code with Node's built-in modules. vulnerability

Weakness · CWE (1)

  • CWE-74 Improper Neutralization of Special Elements in Output Used by a Downstream Component weakness

References