GitHub Advisoryadvisory · npm
GHSA-wjmp-wphq-jvqf Passport-wsfed-saml2 allows SAML Authentication Bypass via Signature Wrapping
CRITICAL
Official page ↗
- Aliases
- CVE-2025-46572
- Ecosystem
- npm
- Packages
- passport-wsfed-saml2
- Severity
- Critical
- CVSS vector
- CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N
- Weaknesses
- CWE-287, CWE-347
- Reviewed
- 2025-05-06
Affected packages
• npm passport-wsfed-saml2: >= 3.0.5, < 4.6.4 → fixed in 4.6.4
Description
Overview
This vulnerability allows an attacker to impersonate any user during SAML authentication by crafting a SAMLResponse. This can be done by using a valid SAML object that was signed by the configured IdP.
Am I Affected?
You are affected by this SAML Signature Wrapping vulnerability if you are using `passport-wsfed-saml2` version 4.6.3 or below, specifically under the following conditions:
1. The service provider is using `passport-wsfed-saml2`,
2. A valid SAML document signed by the Identity Provider can be obtained.
Fix
Upgrade to v4.6.4 or greater.
Related
Alias · CVE (1)
- CVE-2025-46572 passport-wsfed-saml2 provides passport strategy for both WS-fed and SAML2 protocol. vulnerability