GitHub Advisoryadvisory · Packagist
GHSA-wm86-w3cf-h6vm Drupal external link injection vulnerability
MEDIUM
Official page ↗
- Aliases
- CVE-2017-6932
- Ecosystem
- Packagist
- Packages
- drupal/core, drupal/drupal
- Severity
- Moderate
- CVSS vector
- CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-601
- Reviewed
- 2024-04-23
Affected packages
• Packagist drupal/core: >= 7.0, < 7.57 → fixed in 7.57
• Packagist drupal/drupal: >= 7.0, < 7.57 → fixed in 7.57
Description
Drupal core 7.x versions before 7.57 has an external link injection vulnerability when the language switcher block is used. A similar vulnerability exists in various custom and contributed modules. This vulnerability could allow an attacker to trick users into unwillingly navigating to an external site.
Related
Alias · CVE (1)
- CVE-2017-6932 Drupal core 7.x versions before 7.57 has an external link injection vulnerability when the language switcher block is used. vulnerability
Weakness · CWE (1)
- CWE-601 URL Redirection to Untrusted Site weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2017-6932 advisory
- https://github.com/FriendsOfPHP/security-advisories/blob/master/drupal/core/CVE-2017-6932.yaml web
- https://github.com/FriendsOfPHP/security-advisories/blob/master/drupal/drupal/CVE-2017-6932.yaml web
- https://github.com/drupal/core package
- https://lists.debian.org/debian-lts-announce/2018/02/msg00030.html web
- https://www.debian.org/security/2018/dsa-4123 web
- https://www.drupal.org/sa-core-2018-001 web