GitHub Advisoryadvisory · Packagist
GHSA-wmh7-782f-xfw5 Gravity Forms stored Cross-Site Scripting (XSS) vulnerability
MEDIUM
Official page ↗
- Aliases
- CVE-2020-27850
- Ecosystem
- Packagist
- Packages
- wp-premium/gravityforms
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2024-04-24
Affected packages
• Packagist wp-premium/gravityforms: >= 2.4, < 2.4.21 → fixed in 2.4.21
Description
A stored Cross-Site Scripting (XSS) vulnerability in forms import feature in Rocketgenius Gravity Forms before 2.4.21 allows remote attackers to inject arbitrary web script or HTML via the import of a GF form. This code is interpreted by users in a privileged role (Administrator, Editor, etc.).
Related
Alias · CVE (1)
- CVE-2020-27850 A stored Cross-Site Scripting (XSS) vulnerability in forms import feature in Rocketgenius Gravity Forms before 2.4.21 allows remote… vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness