GitHub Advisoryadvisory · Maven
GHSA-wmr8-25ff-ggpj Incorrect Authorization in Jenkins
MEDIUM
Official page ↗
- Aliases
- CVE-2018-1999004
- Ecosystem
- Maven
- Packages
- org.jenkins-ci.main:jenkins-core
- Severity
- Moderate
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L
- Weaknesses
- CWE-863
- Reviewed
- 2022-06-28
Affected packages
• Maven org.jenkins-ci.main:jenkins-core: < 2.121.2 → fixed in 2.121.2
• Maven org.jenkins-ci.main:jenkins-core: >= 2.122, < 2.132 → fixed in 2.132
Description
A Improper authorization vulnerability exists in Jenkins 2.132 and earlier, 2.121.1 and earlier in SlaveComputer.java that allows attackers with Overall/Read permission to initiate agent launches, and abort in-progress agent launches.
Related
Alias · CVE (1)
- CVE-2018-1999004 A Improper authorization vulnerability exists in Jenkins 2.132 and earlier, 2.121.1 and earlier in SlaveComputer.java that allows attackers… vulnerability
Weakness · CWE (1)
- CWE-863 Incorrect Authorization weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2018-1999004 advisory
- https://github.com/jenkinsci/jenkins/commit/40250f08aca7f3f8816f21870ee23463a52ef2f2 web
- https://github.com/jenkinsci/jenkins package
- https://jenkins.io/security/advisory/2018-07-18/#SECURITY-892 web
- https://www.oracle.com/security-alerts/cpuapr2022.html web