GitHub Advisoryadvisory · npm
GHSA-wmx6-vxcf-c3gr Validation Bypass in slp-validate
CRITICAL
Official page ↗
- Aliases
- CVE-2019-16761
- Ecosystem
- npm
- Packages
- slp-validate
- Severity
- Critical
- CVSS vector
- CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:N/I:H/A:H
- Weaknesses
- CWE-20
- Reviewed
- 2020-06-16
Affected packages
• npm slp-validate: >= 1.0.0, < 1.0.1 → fixed in 1.0.1
Description
Versions of `slp-validate` prior to 1.0.1 are vulnerable to a validation bypass. Bitcoin scripts may cause the validation result from `slp-validate` to differ from the specified SLP consensus. This allows an attacker to create a Bitcoin script that causes a hard-fork from the SLP consensus.
Recommendation
Upgrade to version 1.0.1 or later.
Related
Alias · CVE (1)
- CVE-2019-16761 A specially crafted Bitcoin script can cause a discrepancy between the specified SLP consensus rules and the validation result of the… vulnerability
Weakness · CWE (1)
- CWE-20 Improper Input Validation weakness
References
- https://github.com/simpleledger/slp-validate/security/advisories/GHSA-wmx6-vxcf-c3gr web
- https://nvd.nist.gov/vuln/detail/CVE-2019-16761 advisory
- https://github.com/simpleledger/slp-validate/commit/50ad96c2798dad6b9f9a13333dd05232defe5730#diff-fe58606994c412ba56a65141a7aa4a62L123 web
- https://github.com/advisories/GHSA-wmx6-vxcf-c3gr advisory
- https://www.npmjs.com/advisories/1422 web