GitHub Advisoryadvisory · PyPI

GHSA-wp29-qmvj-frvp FoundationAgents MetaGPT vulnerable to os command injection via the Terminal.run_command

MEDIUM Published 2026-04-09 Modified 2026-04-10 Official page ↗
Aliases
CVE-2026-5972
Ecosystem
PyPI
Packages
metagpt
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
Weaknesses
CWE-77
Reviewed
2026-04-10

Affected packages

• PyPI metagpt: < 0.8.2 → fixed in 0.8.2

Description

A vulnerability has been found in FoundationAgents MetaGPT up to 0.8.1. This issue affects the function Terminal.run_command in the library metagpt/tools/libs/terminal.py. The manipulation leads to os command injection. Remote exploitation of the attack is possible. The exploit has been disclosed to the public and may be used. The identifier of the patch is d04ffc8dc67903e8b327f78ec121df5e190ffc7b. Applying a patch is the recommended action to fix this issue.

Related

Alias · CVE (1)

  • CVE-2026-5972 A vulnerability has been found in FoundationAgents MetaGPT up to 0.8.1. vulnerability

Weakness · CWE (1)

  • CWE-77 Improper Neutralization of Special Elements used in a Command weakness

References