GitHub Advisoryadvisory · Packagist

GHSA-wp3g-pr4h-q6vv Moodle does not enforce capability requirements for reading blog comments

MEDIUM Published 2022-05-13 Modified 2024-01-23 Official page ↗
Aliases
CVE-2013-2082
Ecosystem
Packagist
Packages
moodle/moodle
Severity
Moderate
Reviewed
2024-01-23

Affected packages

• Packagist moodle/moodle: < 2.2.10 → fixed in 2.2.10 • Packagist moodle/moodle: >= 2.3.0, < 2.3.7 → fixed in 2.3.7 • Packagist moodle/moodle: >= 2.4.0, < 2.4.4 → fixed in 2.4.4

Description

Moodle through 2.1.10, 2.2.x before 2.2.10, 2.3.x before 2.3.7, and 2.4.x before 2.4.4 does not enforce capability requirements for reading blog comments, which allows remote attackers to obtain sensitive information via a crafted request.

Related

Alias · CVE (1)

  • CVE-2013-2082 Moodle through 2.1.10, 2.2.x before 2.2.10, 2.3.x before 2.3.7, and 2.4.x before 2.4.4 does not enforce capability requirements for reading… vulnerability

References