GitHub Advisoryadvisory · NuGet
GHSA-wp74-jgxh-gv4q Microsoft Security Advisory CVE-2026-50651 – .NET Denial of Service Vulnerability
HIGH
Official page ↗
- Aliases
- CVE-2026-50651
- Ecosystem
- NuGet
- Packages
- Microsoft.NetCore.App.Runtime.linux-arm, Microsoft.NetCore.App.Runtime.linux-arm64, Microsoft.NetCore.App.Runtime.linux-musl-arm, Microsoft.NetCore.App.Runtime.linux-musl-arm64, Microsoft.NetCore.App.Runtime.linux-musl-x64, Microsoft.NetCore.App.Runtime.linux-x64, Microsoft.NetCore.App.Runtime.osx-arm64, Microsoft.NetCore.App.Runtime.osx-x64, Microsoft.NetCore.App.Runtime.win-arm, Microsoft.NetCore.App.Runtime.win-arm64, Microsoft.NetCore.App.Runtime.win-x64, Microsoft.NetCore.App.Runtime.win-x86
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- Weaknesses
- CWE-770
- Reviewed
- 2026-07-20
Affected packages
• NuGet Microsoft.NetCore.App.Runtime.linux-arm: >= 10.0.0, < 10.0.10 → fixed in 10.0.10
• NuGet Microsoft.NetCore.App.Runtime.linux-arm64: >= 10.0.0, < 10.0.10 → fixed in 10.0.10
• NuGet Microsoft.NetCore.App.Runtime.linux-musl-arm: >= 10.0.0, < 10.0.10 → fixed in 10.0.10
• NuGet Microsoft.NetCore.App.Runtime.linux-musl-arm64: >= 10.0.0, < 10.0.10 → fixed in 10.0.10
• NuGet Microsoft.NetCore.App.Runtime.linux-musl-x64: >= 10.0.0, < 10.0.10 → fixed in 10.0.10
• NuGet Microsoft.NetCore.App.Runtime.linux-x64: >= 10.0.0, < 10.0.10 → fixed in 10.0.10
• NuGet Microsoft.NetCore.App.Runtime.osx-arm64: >= 10.0.0, < 10.0.10 → fixed in 10.0.10
• NuGet Microsoft.NetCore.App.Runtime.osx-x64: >= 10.0.0, < 10.0.10 → fixed in 10.0.10
• NuGet Microsoft.NetCore.App.Runtime.win-arm: >= 10.0.0, < 10.0.10 → fixed in 10.0.10
• NuGet Microsoft.NetCore.App.Runtime.win-arm64: >= 10.0.0, < 10.0.10 → fixed in 10.0.10
• NuGet Microsoft.NetCore.App.Runtime.win-x64: >= 10.0.0, < 10.0.10 → fixed in 10.0.10
• NuGet Microsoft.NetCore.App.Runtime.win-x86: >= 10.0.0, < 10.0.10 → fixed in 10.0.10
• NuGet Microsoft.NetCore.App.Runtime.linux-arm: >= 9.0.0, < 9.0.18 → fixed in 9.0.18
• NuGet Microsoft.NetCore.App.Runtime.linux-arm64: >= 9.0.0, < 9.0.18 → fixed in 9.0.18
• NuGet Microsoft.NetCore.App.Runtime.linux-musl-arm: >= 9.0.0, < 9.0.18 → fixed in 9.0.18
• NuGet Microsoft.NetCore.App.Runtime.linux-musl-arm64: >= 9.0.0, < 9.0.18 → fixed in 9.0.18
• NuGet Microsoft.NetCore.App.Runtime.linux-musl-x64: >= 9.0.0, < 9.0.18 → fixed in 9.0.18
• NuGet Microsoft.NetCore.App.Runtime.linux-x64: >= 9.0.0, < 9.0.18 → fixed in 9.0.18
• NuGet Microsoft.NetCore.App.Runtime.osx-arm64: >= 9.0.0, < 9.0.18 → fixed in 9.0.18
• NuGet Microsoft.NetCore.App.Runtime.osx-x64: >= 9.0.0, < 9.0.18 → fixed in 9.0.18
• NuGet Microsoft.NetCore.App.Runtime.win-arm: >= 9.0.0, < 9.0.18 → fixed in 9.0.18
• NuGet Microsoft.NetCore.App.Runtime.win-arm64: >= 9.0.0, < 9.0.18 → fixed in 9.0.18
• NuGet Microsoft.NetCore.App.Runtime.win-x64: >= 9.0.0, < 9.0.18 → fixed in 9.0.18
• NuGet Microsoft.NetCore.App.Runtime.win-x86: >= 9.0.0, < 9.0.18 → fixed in 9.0.18
• NuGet Microsoft.NetCore.App.Runtime.linux-arm: >= 8.0.0, < 8.0.29 → fixed in 8.0.29
• NuGet Microsoft.NetCore.App.Runtime.linux-arm64: >= 8.0.0, < 8.0.29 → fixed in 8.0.29
• NuGet Microsoft.NetCore.App.Runtime.linux-musl-arm: >= 8.0.0, < 8.0.29 → fixed in 8.0.29
• NuGet Microsoft.NetCore.App.Runtime.linux-musl-arm64: >= 8.0.0, < 8.0.29 → fixed in 8.0.29
• NuGet Microsoft.NetCore.App.Runtime.linux-musl-x64: >= 8.0.0, < 8.0.29 → fixed in 8.0.29
• NuGet Microsoft.NetCore.App.Runtime.linux-x64: >= 8.0.0, < 8.0.29 → fixed in 8.0.29
• NuGet Microsoft.NetCore.App.Runtime.osx-arm64: >= 8.0.0, < 8.0.29 → fixed in 8.0.29
• NuGet Microsoft.NetCore.App.Runtime.osx-x64: >= 8.0.0, < 8.0.29 → fixed in 8.0.29
• NuGet Microsoft.NetCore.App.Runtime.win-arm: >= 8.0.0, < 8.0.29 → fixed in 8.0.29
• NuGet Microsoft.NetCore.App.Runtime.win-arm64: >= 8.0.0, < 8.0.29 → fixed in 8.0.29
• NuGet Microsoft.NetCore.App.Runtime.win-x64: >= 8.0.0, < 8.0.29 → fixed in 8.0.29
• NuGet Microsoft.NetCore.App.Runtime.win-x86: >= 8.0.0, < 8.0.29 → fixed in 8.0.29
Description
Executive summary
Microsoft is releasing this security advisory to provide information about a vulnerability in .NET HTTP client (System.Net.Http). This advisory also provides guidance on what developers can do to update their applications to remove this vulnerability.
A denial of service vulnerability exists in .NET 8, .NET 9, and .NET 10 where an attacker can exploit the HTTP/2 protocol to cause an out-of-memory condition.
Announcement
Announcement for this issue can be found at https://github.com/dotnet/announcements/issues/TBD
CVSS Details
• Version: 3.1
• Severity: High
• Score: 7.5
• Vector: `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`
• Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)
Affected Platforms
• Platforms: All
• Architectures: All
Affected Packages
The vulnerability affects any Microsoft .NET project if it uses any of affected package versions listed below
.NET 10.0
Package name | Affected version | Patched version
------------ | ---------------- | -------------------------
Microsoft.NetCore.App.Runtime.linux-arm | >= 10.0.0, = 10.0.0, = 10.0.0, = 10.0.0, = 10.0.0, = 10.0.0, = 10.0.0, = 10.0.0, = 10.0.0, = 10.0.0, = 10.0.0, = 10.0.0, .NET 9.0
Package name | Affected version | Patched version
------------ | ---------------- | -------------------------
Microsoft.NetCore.App.Runtime.linux-arm | >= 9.0.0, = 9.0.0, = 9.0.0, = 9.0.0, = 9.0.0, = 9.0.0, = 9.0.0, = 9.0.0, = 9.0.0, = 9.0.0, = 9.0.0, = 9.0.0, .NET 8.0
Package name | Affected version | Patched version
------------ | ---------------- | -------------------------
Microsoft.NetCore.App.Runtime.linux-arm | >= 8.0.0, = 8.0.0, = 8.0.0, = 8.0.0, = 8.0.0, = 8.0.0, = 8.0.0, = 8.0.0, = 8.0.0, = 8.0.0, = 8.0.0, = 8.0.0, How do I know if I am affected?
If using a package listed in affected packages, you're exposed to the vulnerability.
How do I fix the issue?
1. To fix the issue please install the latest version of .NET. If you have installed one or more .NET SDKs through Visual Studio, Visual Studio will prompt you to update Visual Studio, which will also update your .NET SDKs.
2. If your application references the vulnerable nuget package, update the package reference to the patched version. You can list the versions you have installed by running the `dotnet --info` command.
Once you have installed the updated runtime or SDK, restart your apps for the update to take effect.
Additionall…
Related
Alias · CVE (1)
- CVE-2026-50651 Allocation of resources without limits or throttling in .NET allows an unauthorized attacker to deny service over a network. vulnerability
Weakness · CWE (1)
- CWE-770 Allocation of Resources Without Limits or Throttling weakness
References
- https://github.com/dotnet/runtime/security/advisories/GHSA-wp74-jgxh-gv4q web
- https://nvd.nist.gov/vuln/detail/CVE-2026-50651 advisory
- https://github.com/dotnet/announcements/issues/422 web
- https://github.com/dotnet/runtime/issues/130715 web
- https://github.com/dotnet/runtime package
- https://msrc.microsoft.com/update-guide/vulnerability/CVE-2026-50651 web