GitHub Advisoryadvisory · Packagist
GHSA-wpfp-q843-v772 Cross-site Scripting in moodle
MEDIUM
Official page ↗
- Aliases
- CVE-2021-43558
- Ecosystem
- Packagist
- Packages
- moodle/moodle
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2022-06-17
Affected packages
• Packagist moodle/moodle: >= 3.11.0, < 3.11.4 → fixed in 3.11.4
• Packagist moodle/moodle: >= 3.10.0, < 3.10.8 → fixed in 3.10.8
• Packagist moodle/moodle: >= 3.9.0, < 3.9.11 → fixed in 3.9.11
Description
A flaw was found in Moodle in versions 3.11 to 3.11.3, 3.10 to 3.10.7, 3.9 to 3.9.10 and earlier unsupported versions. A URL parameter in the filetype site administrator tool required extra sanitizing to prevent a reflected XSS risk.
Related
Alias · CVE (1)
- CVE-2021-43558 A flaw was found in Moodle in versions 3.11 to 3.11.3, 3.10 to 3.10.7, 3.9 to 3.9.10 and earlier unsupported versions. vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness