GitHub Advisoryadvisory · npm

GHSA-wpg7-2c88-r8xv Exposure of Sensitive Information in simple-get

HIGH Published 2022-01-28 Modified 2022-02-03 Official page ↗
Aliases
CVE-2022-0355
Ecosystem
npm
Packages
simple-get
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Weaknesses
CWE-200
Reviewed
2022-01-27

Affected packages

• npm simple-get: >= 4.0.0, < 4.0.1 → fixed in 4.0.1 • npm simple-get: >= 3.0.0, < 3.1.1 → fixed in 3.1.1 • npm simple-get: < 2.8.2 → fixed in 2.8.2

Description

In versions of simple-get prior to 4.0.1, 3.1.1, and 2.8.2, when fetching a remote url with a cookie location response, headers will be followed, potentially resulting in an exposure of the session cookie to a third party.

Related

Alias · CVE (1)

  • CVE-2022-0355 Improper Removal of Sensitive Information Before Storage or Transfer in NPM simple-get prior to 4.0.1. vulnerability

Weakness · CWE (1)

  • CWE-200 Exposure of Sensitive Information to an Unauthorized Actor weakness

References