GitHub Advisoryadvisory · Packagist

GHSA-wph3-44rj-92pr elFinder before 2.1.59 contains multiple vulnerabilities leading to RCE

CRITICAL Published 2021-06-16 Modified 2022-08-11 Official page ↗
Aliases
CVE-2021-32682
Ecosystem
Packagist
Packages
studio-42/elfinder
Severity
Critical
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-22, CWE-78, CWE-918
Reviewed
2021-06-15

Affected packages

• Packagist studio-42/elfinder: < 2.1.59 → fixed in 2.1.59

Description

Impact We recently fixed several vulnerabilities affect elFinder 2.1.58. These vulnerabilities can allow an attacker to execute arbitrary code and commands on the server hosting the elFinder PHP connector, even with the minimal configuration. Patches The issues were addressed in our last release, 2.1.59. Workarounds If you can't update to 2.1.59, make sure your connector is not exposed without authentication. Reference Further technical details will be disclosed on https://blog.sonarsource.com/tag/security after some time. For more information If you have any questions or comments about this advisory, you can contact: • The original reporters, by sending an email to [email protected]; • The maintainers, by opening an issue on this repository.

Related

Alias · CVE (1)

  • CVE-2021-32682 elFinder is an open-source file manager for web, written in JavaScript using jQuery UI. vulnerability

Weakness · CWE (3)

  • CWE-22 Improper Limitation of a Pathname to a Restricted Directory weakness
  • CWE-78 Improper Neutralization of Special Elements used in an OS Command weakness
  • CWE-918 Server-Side Request Forgery weakness

References