GitHub Advisoryadvisory · Maven
GHSA-wpr6-qvcq-8269 Stored Cross-site Scripting vulnerability in Jenkins Subversion Plugin
MEDIUM
Official page ↗
- Aliases
- CVE-2022-29046
- Ecosystem
- Maven
- Packages
- org.jenkins-ci.plugins:subversion
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2022-12-01
Affected packages
• Maven org.jenkins-ci.plugins:subversion: < 2.15.4 → fixed in 2.15.4
Description
Jenkins Subversion Plugin 2.15.3 and earlier does not escape the name and description of List Subversion tags (and more) parameters on views displaying parameters, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Item/Configure permission.
Exploitation of this vulnerability requires that parameters are listed on another page, like the \"Build With Parameters\" and \"Parameters\" pages provided by Jenkins (core), and that those pages are not hardened to prevent exploitation. Jenkins (core) has prevented exploitation of vulnerabilities of this kind on the \"Build With Parameters\" and \"Parameters\" pages since 2.44 and LTS 2.32.2 as part of the SECURITY-353 / CVE-2017-2601 fix.
Related
Alias · CVE (1)
- CVE-2022-29046 Jenkins Subversion Plugin 2.15.3 and earlier does not escape the name and description of List Subversion tags (and more) parameters on… vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness