GitHub Advisoryadvisory · Packagist
GHSA-wpww-hx7x-xfjh phpMyAdmin PHP code injection
HIGH
Official page ↗
- Aliases
- CVE-2016-6609
- Ecosystem
- Packagist
- Packages
- phpmyadmin/phpmyadmin
- Severity
- High
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-77
- Reviewed
- 2024-04-24
Affected packages
• Packagist phpmyadmin/phpmyadmin: >= 4.6, < 4.6.4 → fixed in 4.6.4
• Packagist phpmyadmin/phpmyadmin: >= 4.4, < 4.4.15.8 → fixed in 4.4.15.8
• Packagist phpmyadmin/phpmyadmin: >= 4.0, < 4.0.10.17 → fixed in 4.0.10.17
Description
An issue was discovered in phpMyAdmin. A specially crafted database name could be used to run arbitrary PHP commands through the array export feature. All 4.6.x versions (prior to 4.6.4), 4.4.x versions (prior to 4.4.15.8), and 4.0.x versions (prior to 4.0.10.17) are affected.
Related
Alias · CVE (1)
- CVE-2016-6609 An issue was discovered in phpMyAdmin. vulnerability
Weakness · CWE (1)
- CWE-77 Improper Neutralization of Special Elements used in a Command weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2016-6609 advisory
- https://github.com/phpmyadmin/composer package
- https://lists.debian.org/debian-lts-announce/2018/07/msg00006.html web
- https://security.gentoo.org/glsa/201701-32 web
- https://www.phpmyadmin.net/security/PMASA-2016-32 web
- http://www.securityfocus.com/bid/94112 web