GitHub Advisoryadvisory · RubyGems

GHSA-wq4h-7r42-5hrr Possible shell escape sequence injection vulnerability in Rack

CRITICAL Published 2022-05-27 Modified 2022-12-07 Official page ↗
Aliases
CVE-2022-30123
Ecosystem
RubyGems
Packages
rack
Severity
Critical
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
Weaknesses
CWE-150
Reviewed
2022-05-27

Affected packages

• RubyGems rack: < 2.0.9.1 → fixed in 2.0.9.1 • RubyGems rack: >= 2.1, < 2.1.4.1 → fixed in 2.1.4.1 • RubyGems rack: >= 2.2, < 2.2.3.1 → fixed in 2.2.3.1

Description

There is a possible shell escape sequence injection vulnerability in the Lint and CommonLogger components of Rack. This vulnerability has been assigned the CVE identifier CVE-2022-30123. Versions Affected: All. Not affected: None Fixed Versions: 2.0.9.1, 2.1.4.1, 2.2.3.1 Impact Carefully crafted requests can cause shell escape sequences to be written to the terminal via Rack's Lint middleware and CommonLogger middleware. These escape sequences can be leveraged to possibly execute commands in the victim's terminal. Impacted applications will have either of these middleware installed, and vulnerable apps may have something like this: ``` use Rack::Lint ``` Or ``` use Rack::CommonLogger ``` All users running an affected release should either upgrade or use one of the workarounds immediately. Workarounds Remove these middleware from your application

Related

Alias · CVE (1)

  • CVE-2022-30123 A sequence injection vulnerability exists in Rack <2.0.9.1, <2.1.4.1 and <2.2.3.1 which could allow is a possible shell escape in the Lint… vulnerability

Weakness · CWE (1)

  • CWE-150 Improper Neutralization of Escape, Meta, or Control Sequences weakness

References