GitHub Advisoryadvisory · Packagist
GHSA-wq8p-mqvg-2p5h laravel framework SQL Injection via limit and offset functions
HIGH
Official page ↗
- Ecosystem
- Packagist
- Packages
- laravel/framework
- Severity
- High
- Weaknesses
- CWE-89
- Reviewed
- 2024-05-15
Affected packages
• Packagist laravel/framework: >= 6.0.0, < 6.20.26 → fixed in 6.20.26
• Packagist laravel/framework: >= 7.0.0, < 7.30.5 → fixed in 7.30.5
• Packagist laravel/framework: >= 8.0.0, < 8.40.0 → fixed in 8.40.0
Description
Impact
Those using SQL Server with Laravel and allowing user input to be passed directly to the limit and offset functions are vulnerable to SQL injection. Other database drivers such as MySQL and Postgres are not affected by this vulnerability.
Patches
This problem has been patched on Laravel versions 6.20.26, 7.30.5, and 8.40.0.
Workarounds
You may workaround this vulnerability by ensuring that only integers are passed to the limit and offset functions, as well as the skip and take functions.
Related
Weakness · CWE (1)
- CWE-89 Improper Neutralization of Special Elements used in an SQL Command weakness