GitHub Advisoryadvisory · npm

GHSA-wqg7-vrj7-v82h Mosca REDoS Vulnerability

HIGH Published 2018-08-31 Modified 2023-09-07 Official page ↗
Aliases
CVE-2018-11615
Ecosystem
npm
Packages
mosca
Severity
High
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weaknesses
CWE-185, CWE-20
Reviewed
2020-06-16

Affected packages

• npm mosca: < 2.8.2 → fixed in 2.8.2

Description

This vulnerability allows remote attackers to deny service on vulnerable installations of npm mosca 2.8.1. Authentication is not required to exploit this vulnerability. The specific flaw exists within the processing of topics. A crafted regular expression can cause the broker to crash. An attacker can leverage this vulnerability to deny access to the target system.

Related

Alias · CVE (1)

  • CVE-2018-11615 This vulnerability allows remote attackers to deny service on vulnerable installations of npm mosca 2.8.1. vulnerability

Weakness · CWE (2)

  • CWE-185 Incorrect Regular Expression weakness
  • CWE-20 Improper Input Validation weakness

References