GitHub Advisoryadvisory · Packagist

GHSA-wqm8-jx8r-8rcq Cross-site scripting vulnerabilities in old version of bundled TinyMCE

MEDIUM Published 2023-04-26 Modified 2023-04-26 Official page ↗
Ecosystem
Packagist
Packages
silverstripe/admin
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N
Reviewed
2023-04-26

Affected packages

• Packagist silverstripe/admin: < 1.12.7 → fixed in 1.12.7

Description

An old version of TinyMCE include an XSS vulnerability, which was patched in a later version. This was described by TinyMCE: > A cross-site scripting (XSS) vulnerability was discovered in the core parser. The vulnerability allowed arbitrary JavaScript execution when inserting a specially crafted piece of content into the editor via the clipboard or APIs. This impacts all users who are using TinyMCE 4.9.10 or lower and TinyMCE 5.4.0 or lower. We reviewed the potential impact of this vulnerability within the context of Silverstripe CMS. We concluded this is a medium impact vulnerability given how TinyMCE is used by Silverstripe CMS. Reported by: Developers at ACC

References