GitHub Advisoryadvisory · Go
GHSA-wqxv-w64v-5wh6 Suspended Coder users retain access to AI Bridge LLM proxy endpoints
MEDIUM
Official page ↗
- Aliases
- CVE-2026-55435
- Ecosystem
- Go
- Packages
- github.com/coder/coder/v2
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N
- Weaknesses
- CWE-863
- Reviewed
- 2026-07-06
Affected packages
• Go github.com/coder/coder/v2: >= 2.34.0, < 2.34.2 → fixed in 2.34.2
• Go github.com/coder/coder/v2: >= 2.33.0, < 2.33.8 → fixed in 2.33.8
• Go github.com/coder/coder/v2: >= 2.30.0, < 2.32.7 → fixed in 2.32.7
Description
Summary
AI Bridge proxy endpoints authenticate via `Server.IsAuthorized` in `coderd/aibridgedserver`, which validates key format, expiry, secret and deleted or system users but does not check whether the account is suspended. Because suspension does not revoke existing API keys, a suspended user's unexpired token keeps working.
> Note: Practical impact is limited to already-issued API keys of suspended users until those keys are deleted.
Impact
A suspended user with a previously issued long-lived token could continue calling AI Bridge LLM proxy endpoints, consuming paid provider resources billed to the deployment and, if injected MCP tools are enabled, invoking those tools. Access persists until the token expires, which may be months after suspension.
Patches
The fix makes AI Bridge authorization reject non-active users like the standard API key middleware. AI Bridge was introduced in v2.30.0. The v2.29 ESR line is not affected.
The fix is available in the following releases:
| Release line | Patched version |
|---|---|
| 2.34 | v2.34.2 |
| 2.33 | v2.33.8 |
| 2.32 | v2.32.7 |
Workarounds
On suspension, delete the user's API keys via `DELETE /api/v2/users/{user}/keys`.
Resources
• Fix: #26173
Credits
Coder would like to thank Anthropic's Security Team (ANT-2026-22446) for independently disclosing this issue!
Related
Alias · CVE (1)
- CVE-2026-55435 Coder allows organizations to provision remote development environments via Terraform. vulnerability
Weakness · CWE (1)
- CWE-863 Incorrect Authorization weakness
References
- https://github.com/coder/coder/security/advisories/GHSA-wqxv-w64v-5wh6 web
- https://nvd.nist.gov/vuln/detail/CVE-2026-55435 advisory
- https://github.com/coder/coder/pull/26164 web
- https://github.com/coder/coder/pull/26173 web
- https://github.com/coder/coder/commit/0d2c9f904a8b75b888140fcc8fbf4633660cc787 web
- https://github.com/coder/coder package
- https://github.com/coder/coder/releases/tag/v2.32.7 web
- https://github.com/coder/coder/releases/tag/v2.33.8 web
- https://github.com/coder/coder/releases/tag/v2.34.2 web