GitHub Advisoryadvisory · Packagist

GHSA-wr57-3h2f-3q95 Magento affected by a server-side denial-of-service using a GraphQL field

HIGH Published 2022-05-24 Modified 2025-11-10 Official page ↗
Aliases
CVE-2021-36044
Ecosystem
Packagist
Packages
magento/project-community-edition, magento/community-edition
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weaknesses
CWE-20
Reviewed
2025-11-07

Affected packages

• Packagist magento/project-community-edition: <= 2.0.2 (no fix yet) • Packagist magento/community-edition: 2.4.2 (no fix yet) • Packagist magento/community-edition: >= 2.4.2-p1, < 2.4.2-p2 → fixed in 2.4.2-p2 • Packagist magento/community-edition: 2.3.7 (no fix yet) • Packagist magento/community-edition: < 2.3.7-p1 → fixed in 2.3.7-p1

Description

Magento Commerce versions 2.4.2 (and earlier), 2.4.2-p1 (and earlier) and 2.3.7 (and earlier) are affected by an improper input validation vulnerability. An unauthenticated attacker could abuse this vulnerability to cause a server-side denial-of-service using a GraphQL field.

Related

Alias · CVE (1)

  • CVE-2021-36044 Magento Commerce versions 2.4.2 (and earlier), 2.4.2-p1 (and earlier) and 2.3.7 (and earlier) are affected by an improper input validation… vulnerability

Weakness · CWE (1)

  • CWE-20 Improper Input Validation weakness

References