GitHub Advisoryadvisory · Maven

GHSA-wr62-c79q-cv37 Apache Tomcat Catalina is vulnerable to DoS attack through bypassing of size limits

HIGH Published 2025-07-10 Modified 2026-03-06 Official page ↗
Aliases
CVE-2025-52520
Ecosystem
Maven
Packages
org.apache.tomcat:tomcat-catalina, org.apache.tomcat.embed:tomcat-embed-core
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weaknesses
CWE-190
Reviewed
2025-07-11

Affected packages

• Maven org.apache.tomcat:tomcat-catalina: >= 11.0.0-M1, < 11.0.9 → fixed in 11.0.9 • Maven org.apache.tomcat:tomcat-catalina: >= 10.1.0-M1, < 10.1.43 → fixed in 10.1.43 • Maven org.apache.tomcat:tomcat-catalina: >= 9.0.0.M1, < 9.0.107 → fixed in 9.0.107 • Maven org.apache.tomcat:tomcat-catalina: >= 8.5.0, <= 8.5.100 (no fix yet) • Maven org.apache.tomcat.embed:tomcat-embed-core: >= 11.0.0-M1, < 11.0.9 → fixed in 11.0.9 • Maven org.apache.tomcat.embed:tomcat-embed-core: >= 10.1.0-M1, < 10.1.43 → fixed in 10.1.43 • Maven org.apache.tomcat.embed:tomcat-embed-core: >= 9.0.0.M1, < 9.0.107 → fixed in 9.0.107 • Maven org.apache.tomcat.embed:tomcat-embed-core: >= 8.5.0, <= 8.5.100 (no fix yet)

Description

For some unlikely configurations of multipart upload, an Integer Overflow vulnerability in Apache Tomcat could lead to a DoS via bypassing of size limits. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.8, from 10.1.0-M1 through 10.1.42, from 9.0.0.M1 through 9.0.106. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.0 through 8.5.100. Other, older, EOL versions may also be affected. Users are recommended to upgrade to version 11.0.9, 10.1.43 or 9.0.107, which fix the issue.

Related

Alias · CVE (1)

  • CVE-2025-52520 For some unlikely configurations of multipart upload, an Integer Overflow vulnerability in Apache Tomcat could lead to a DoS via bypassing… vulnerability

Weakness · CWE (1)

  • CWE-190 Integer Overflow or Wraparound weakness

References