GitHub Advisoryadvisory · Packagist
GHSA-wr6q-xv23-rfq9 Moodle Incorrect Authorization
MEDIUM
Official page ↗
- Aliases
- CVE-2021-40692
- Ecosystem
- Packagist
- Packages
- moodle/moodle
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
- Weaknesses
- CWE-863
- Reviewed
- 2024-04-23
Affected packages
• Packagist moodle/moodle: >= 3.11, < 3.11.3 → fixed in 3.11.3
• Packagist moodle/moodle: >= 3.10, < 3.10.7 → fixed in 3.10.7
• Packagist moodle/moodle: >= 3.9, < 3.9.10 → fixed in 3.9.10
Description
Insufficient capability checks made it possible for teachers to download users outside of their courses.
Related
Alias · CVE (1)
- CVE-2021-40692 Insufficient capability checks made it possible for teachers to download users outside of their courses. vulnerability
Weakness · CWE (1)
- CWE-863 Incorrect Authorization weakness