GitHub Advisoryadvisory · PyPI

GHSA-wrf2-2rch-cmr9 Plone is vulnerable to denial of service

HIGH Published 2022-05-17 Modified 2024-10-14 Official page ↗
Aliases
CVE-2012-5499
Ecosystem
PyPI
Packages
Plone
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weaknesses
CWE-770
Reviewed
2023-02-08

Affected packages

• PyPI Plone: >= 4.0, < 4.2.3 → fixed in 4.2.3 • PyPI Plone: >= 4.3a1, < 4.3b1 → fixed in 4.3b1

Description

python_scripts.py in Plone before 4.2.3 and 4.3 before beta 1 allows remote attackers to cause a denial of service (memory consumption) via a large value, related to `formatColumns`.

Related

Alias · CVE (1)

  • CVE-2012-5499 python_scripts.py in Plone before 4.2.3 and 4.3 before beta 1 allows remote attackers to cause a denial of service (memory consumption) via… vulnerability

Weakness · CWE (1)

  • CWE-770 Allocation of Resources Without Limits or Throttling weakness

References