GitHub Advisoryadvisory · Packagist
GHSA-wrhx-3pxr-6vgg Wikimedia MediaWiki Incorrect Access Control vulnerability
CRITICAL
Official page ↗
- Aliases
- CVE-2019-12468
- Ecosystem
- Packagist
- Packages
- mediawiki/core
- Severity
- Critical
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-284
- Reviewed
- 2024-05-15
Affected packages
• Packagist mediawiki/core: >= 1.27.0, < 1.27.6 → fixed in 1.27.6
• Packagist mediawiki/core: >= 1.30.0, < 1.30.2 → fixed in 1.30.2
• Packagist mediawiki/core: >= 1.31.0, < 1.31.2 → fixed in 1.31.2
• Packagist mediawiki/core: >= 1.32.0, < 1.32.2 → fixed in 1.32.2
Description
An Incorrect Access Control vulnerability was found in Wikimedia MediaWiki 1.27.0 through 1.32.1. Directly POSTing to Special:ChangeEmail would allow for bypassing re-authentication, allowing for potential account takeover.
Related
Alias · CVE (1)
- CVE-2019-12468 An Incorrect Access Control vulnerability was found in Wikimedia MediaWiki 1.27.0 through 1.32.1. vulnerability
Weakness · CWE (1)
- CWE-284 Improper Access Control weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2019-12468 advisory
- https://github.com/FriendsOfPHP/security-advisories/blob/master/mediawiki/core/CVE-2019-12468.yaml web
- https://github.com/wikimedia/mediawiki package
- https://lists.wikimedia.org/pipermail/mediawiki-announce web
- https://lists.wikimedia.org/pipermail/wikitech-l/2019-June/092152.html web
- https://phabricator.wikimedia.org/T197279 web
- https://seclists.org/bugtraq/2019/Jun/12 web
- https://www.debian.org/security/2019/dsa-4460 web