GitHub Advisoryadvisory · Packagist
GHSA-wrjc-fmfq-w3jr baserCMS has a Cross-site Scripting (XSS) Vulnerability in Blog posts and Contents list Feature
MEDIUM
Official page ↗
- Aliases
- CVE-2024-46994
- Ecosystem
- Packagist
- Packages
- baserproject/basercms
- Severity
- Moderate
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2024-10-24
Affected packages
• Packagist baserproject/basercms: < 5.1.2 → fixed in 5.1.2
Description
XSS vulnerability in Blog posts and Contents list Feature to baserCMS.
Target
baserCMS 5.1.1 and earlier versions
Vulnerability
Malicious code may be executed in Blog posts and Contents list feature.
Countermeasures
Update to the latest version of baserCMS
Please refer to the following page to reference for more information.
https://basercms.net/security/JVN_00876083
Credits
Kyohei Ota@LEON TECHNOLOGY,Inc.
Related
Alias · CVE (1)
- CVE-2024-46994 baserCMS is a website development framework. vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness