GitHub Advisoryadvisory · Maven
GHSA-wrqc-q8p5-76m5 Incorrect Authorization in Jenkins Gerrit Trigger Plugin
MEDIUM
Official page ↗
- Aliases
- CVE-2018-1000105
- Ecosystem
- Maven
- Packages
- com.sonyericsson.hudson.plugins.gerrit:gerrit-trigger
- Severity
- Moderate
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
- Weaknesses
- CWE-863
- Reviewed
- 2022-11-01
Affected packages
• Maven com.sonyericsson.hudson.plugins.gerrit:gerrit-trigger: < 2.27.5 → fixed in 2.27.5
Description
An improper authorization vulnerability exists in Jenkins Gerrit Trigger Plugin 2.27.4 and earlier in GerritManagement.java, GerritServer.java, and PluginImpl.java that allows an attacker with Overall/Read access to retrieve some configuration information about Gerrit in Jenkins.
Related
Alias · CVE (1)
- CVE-2018-1000105 An improper authorization vulnerability exists in Jenkins Gerrit Trigger Plugin 2.27.4 and earlier in GerritManagement.java,… vulnerability
Weakness · CWE (1)
- CWE-863 Incorrect Authorization weakness