GitHub Advisoryadvisory · Maven

GHSA-wrr5-p265-7252 Jenkins Warnings NG Plugin Cross-site scripting vulnerability

MEDIUM Published 2022-05-24 Modified 2024-01-30 Official page ↗
Aliases
CVE-2019-10325
Ecosystem
Maven
Packages
io.jenkins.plugins:warnings-ng
Severity
Moderate
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Weaknesses
CWE-79
Reviewed
2024-01-30

Affected packages

• Maven io.jenkins.plugins:warnings-ng: < 5.1.0 → fixed in 5.1.0

Description

A cross-site scripting vulnerability in Jenkins Warnings NG Plugin 5.0.0 and earlier allowed attacker with Job/Configure permission to inject arbitrary JavaScript in build overview pages.

Related

Alias · CVE (1)

  • CVE-2019-10325 A cross-site scripting vulnerability in Jenkins Warnings NG Plugin 5.0.0 and earlier allowed attacker with Job/Configure permission to… vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References