GitHub Advisoryadvisory · npm
GHSA-wrvr-8mpx-r7pp mime Regular Expression Denial of Service when MIME lookup performed on untrusted user input
HIGH
Official page ↗
- Aliases
- CVE-2017-16138
- Ecosystem
- npm
- Packages
- mime
- Severity
- High
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- Weaknesses
- CWE-400
- Reviewed
- 2020-06-16
Affected packages
• npm mime: >= 2.0.0, < 2.0.3 → fixed in 2.0.3
• npm mime: < 1.4.1 → fixed in 1.4.1
Description
Affected versions of `mime` are vulnerable to regular expression denial of service when a mime lookup is performed on untrusted user input.
Recommendation
Update to version 2.0.3 or later.
Related
Alias · CVE (1)
- CVE-2017-16138 The mime module < 1.4.1, 2.0.1, 2.0.2 is vulnerable to regular expression denial of service when a mime lookup is performed on untrusted… vulnerability
Weakness · CWE (1)
- CWE-400 Uncontrolled Resource Consumption weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2017-16138 advisory
- https://github.com/broofa/node-mime/issues/167 web
- https://github.com/broofa/mime/commit/1df903fdeb9ae7eaa048795b8d580ce2c98f40b0 web
- https://github.com/broofa/mime/commit/855d0c4b8b22e4a80b9401a81f2872058eae274d web
- https://github.com/broofa/mime package