GitHub Advisoryadvisory · npm
GHSA-wv67-9jq7-8r69 Improper Input Validation and Buffer Over-read in mqtt-packet
HIGH
Official page ↗
- Aliases
- CVE-2019-5432
- Ecosystem
- npm
- Packages
- mqtt-packet
- Severity
- High
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- Weaknesses
- CWE-125, CWE-126
- Reviewed
- 2019-05-10
Affected packages
• npm mqtt-packet: < 3.5.1 → fixed in 3.5.1
• npm mqtt-packet: >= 4.0.0, < 4.1.3 → fixed in 4.1.3
• npm mqtt-packet: >= 5.0.0, < 5.6.1 → fixed in 5.6.1
• npm mqtt-packet: >= 6.0.0, < 6.1.2 → fixed in 6.1.2
Description
A specifically malformed MQTT Subscribe packet crashes MQTT Brokers using the mqtt-packet module versions < 3.5.1, 4.0.0 - 4.1.3, 5.0.0 - 5.6.1, 6.0.0 - 6.1.2 for decoding.
Related
Alias · CVE (1)
- CVE-2019-5432 A specifically malformed MQTT Subscribe packet crashes MQTT Brokers using the mqtt-packet module versions < 3.5.1, 4.0.0 - 4.1.3, 5.0.0 -… vulnerability