GitHub Advisoryadvisory · Packagist

GHSA-wv8g-fx9j-q2jg phpMyAdmin cross-site scripting Vulnerability via ENUM value

LOW Published 2022-05-17 Modified 2023-08-16 Official page ↗
Aliases
CVE-2014-7217
Ecosystem
Packagist
Packages
phpmyadmin/phpmyadmin
Severity
Low
Weaknesses
CWE-79
Reviewed
2023-08-16

Affected packages

• Packagist phpmyadmin/phpmyadmin: >= 4.0.0, < 4.0.10.4 → fixed in 4.0.10.4 • Packagist phpmyadmin/phpmyadmin: >= 4.1.0, < 4.1.14.5 → fixed in 4.1.14.5 • Packagist phpmyadmin/phpmyadmin: >= 4.2.0, < 4.2.9.1 → fixed in 4.2.9.1

Description

Multiple cross-site scripting (XSS) vulnerabilities in phpMyAdmin 4.0.x before 4.0.10.4, 4.1.x before 4.1.14.5, and 4.2.x before 4.2.9.1 allow remote authenticated users to inject arbitrary web script or HTML via a crafted ENUM value that is improperly handled during rendering of the (1) table search or (2) table structure page, related to `libraries/TableSearch.class.php` and `libraries/Util.class.php`.

Related

Alias · CVE (1)

  • CVE-2014-7217 Multiple cross-site scripting (XSS) vulnerabilities in phpMyAdmin 4.0.x before 4.0.10.4, 4.1.x before 4.1.14.5, and 4.2.x before 4.2.9.1… vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References