GitHub Advisoryadvisory · Go
GHSA-wvgv-4fc3-2rcp Mattermost doesn't prevent disclosure of created user password
MEDIUM
Official page ↗
- Aliases
- CVE-2026-6345
- Ecosystem
- Go
- Packages
- github.com/mattermost/mattermost/server/v8, github.com/mattermost/mattermost-server
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:N
- Weaknesses
- CWE-522
- Reviewed
- 2026-06-01
Affected packages
• Go github.com/mattermost/mattermost/server/v8: >= 11.5.0, < 11.5.2 → fixed in 11.5.2
• Go github.com/mattermost/mattermost/server/v8: >= 10.11.0, < 10.11.14 → fixed in 10.11.14
• Go github.com/mattermost/mattermost/server/v8: >= 11.4.0, < 11.4.4 → fixed in 11.4.4
• Go github.com/mattermost/mattermost/server/v8: < 8.0.0-20260311102650-3057ae7e83e9 → fixed in 8.0.0-20260311102650-3057ae7e83e9
• Go github.com/mattermost/mattermost-server: < 5.3.2-0.20260311102650-3057ae7e83e9 → fixed in 5.3.2-0.20260311102650-3057ae7e83e9
Description
Mattermost versions 11.5.x <= 11.5.1, 10.11.x <= 10.11.13, 11.4.x <= 11.4.3 doesn't prevent disclosure of created user password which allows a malicious attacker to impersonate a user via the use of some of those passwords.. Mattermost Advisory ID: MMSA-2026-00614
Related
Alias · CVE (1)
- CVE-2026-6345 Mattermost versions 11.5.x <= 11.5.1, 10.11.x <= 10.11.13, 11.4.x <= 11.4.3 fail prevent disclosure of created user password which allows a… vulnerability
Weakness · CWE (1)
- CWE-522 Insufficiently Protected Credentials weakness