GitHub Advisoryadvisory · Packagist

GHSA-wvj5-r78r-hhfq Symfony Authentication Bypass

CRITICAL Published 2022-05-14 Modified 2024-02-08 Official page ↗
Aliases
CVE-2016-2403
Ecosystem
Packagist
Packages
symfony/security-core, symfony/security, symfony/symfony
Severity
Critical
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-287
Reviewed
2023-07-31

Affected packages

• Packagist symfony/security-core: >= 2.8.0, < 2.8.6 → fixed in 2.8.6 • Packagist symfony/security-core: >= 3.0.0, < 3.0.6 → fixed in 3.0.6 • Packagist symfony/security: >= 2.8.0, < 2.8.6 → fixed in 2.8.6 • Packagist symfony/security: >= 3.0.0, < 3.0.6 → fixed in 3.0.6 • Packagist symfony/symfony: >= 2.8.0, < 2.8.6 → fixed in 2.8.6 • Packagist symfony/symfony: >= 3.0.0, < 3.0.6 → fixed in 3.0.6

Description

Symfony before 2.8.6 and 3.x before 3.0.6 allows remote attackers to bypass authentication by logging in with an empty password and valid username, which triggers an unauthenticated bind.

Related

Alias · CVE (1)

  • CVE-2016-2403 Symfony before 2.8.6 and 3.x before 3.0.6 allows remote attackers to bypass authentication by logging in with an empty password and valid… vulnerability

Weakness · CWE (1)

  • CWE-287 Improper Authentication weakness

References