GitHub Advisoryadvisory · Go
GHSA-wvjg-33p9-938h Mattermost Server does not properly restrict use of slash commands
HIGH
Official page ↗
- Aliases
- CVE-2017-18886
- Ecosystem
- Go
- Packages
- github.com/mattermost/mattermost-server
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-732
- Reviewed
- 2025-12-05
Affected packages
• Go github.com/mattermost/mattermost-server: < 4.1.2 → fixed in 4.1.2
• Go github.com/mattermost/mattermost-server: >= 4.2.0-rc1, < 4.2.1 → fixed in 4.2.1
• Go github.com/mattermost/mattermost-server: >= 4.3.0-rc1, < 4.3.0 → fixed in 4.3.0
Description
An issue was discovered in Mattermost Server before 4.3.0, 4.2.1, and 4.1.2. It allows a bypass of restrictions on use of slash commands.
Related
Alias · CVE (1)
- CVE-2017-18886 An issue was discovered in Mattermost Server before 4.3.0, 4.2.1, and 4.1.2. vulnerability
Weakness · CWE (1)
- CWE-732 Incorrect Permission Assignment for Critical Resource weakness