GitHub Advisoryadvisory · PyPI

GHSA-wvjw-p9f5-vq28 Segfault in `tf.raw_ops.SparseCountSparseOutput`

LOW Published 2021-05-21 Modified 2024-11-13 Official page ↗
Aliases
CVE-2021-29619
Ecosystem
PyPI
Packages
tensorflow, tensorflow-cpu, tensorflow-gpu
Severity
Low
CVSS vector
CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:N/I:N/A:L
Weaknesses
CWE-755
Reviewed
2021-05-17

Affected packages

• PyPI tensorflow: < 2.1.4 → fixed in 2.1.4 • PyPI tensorflow: >= 2.2.0, < 2.2.3 → fixed in 2.2.3 • PyPI tensorflow: >= 2.3.0, < 2.3.3 → fixed in 2.3.3 • PyPI tensorflow: >= 2.4.0, < 2.4.2 → fixed in 2.4.2 • PyPI tensorflow-cpu: < 2.1.4 → fixed in 2.1.4 • PyPI tensorflow-cpu: >= 2.2.0, < 2.2.3 → fixed in 2.2.3 • PyPI tensorflow-cpu: >= 2.3.0, < 2.3.3 → fixed in 2.3.3 • PyPI tensorflow-cpu: >= 2.4.0, < 2.4.2 → fixed in 2.4.2 • PyPI tensorflow-gpu: < 2.1.4 → fixed in 2.1.4 • PyPI tensorflow-gpu: >= 2.2.0, < 2.2.3 → fixed in 2.2.3 • PyPI tensorflow-gpu: >= 2.3.0, < 2.3.3 → fixed in 2.3.3 • PyPI tensorflow-gpu: >= 2.4.0, < 2.4.2 → fixed in 2.4.2

Description

Impact Passing invalid arguments (e.g., discovered via fuzzing) to `tf.raw_ops.SparseCountSparseOutput` results in segfault. Patches We have patched the issue in GitHub commit 82e6203221865de4008445b13c69b6826d2b28d9. The fix will be included in TensorFlow 2.5.0. We will also cherrypick this commit on TensorFlow 2.4.2, TensorFlow 2.3.3, TensorFlow 2.2.3 and TensorFlow 2.1.4, as these are also affected and still in supported range. For more information Please consult our security guide for more information regarding the security model and how to contact us with issues and questions.

Related

Alias · CVE (1)

  • CVE-2021-29619 TensorFlow is an end-to-end open source platform for machine learning. vulnerability

Weakness · CWE (1)

  • CWE-755 Improper Handling of Exceptional Conditions weakness

References