GitHub Advisoryadvisory · npm
GHSA-ww2v-frv5-pj5x Joplin is vulnerable to arbitrary code execution
CRITICAL
Official page ↗
- Aliases
- CVE-2022-35131
- Ecosystem
- npm
- Packages
- joplin
- Severity
- Critical
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H
- Weaknesses
- CWE-79
- Reviewed
- 2022-07-29
Affected packages
• npm joplin: < 2.9.1 → fixed in 2.9.1
Description
Joplin v2.8.8 allows attackers to execute arbitrary commands via a crafted payload injected into the Node titles.
Related
Alias · CVE (1)
- CVE-2022-35131 Joplin v2.8.8 allows attackers to execute arbitrary commands via a crafted payload injected into the Node titles. vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2022-35131 advisory
- https://github.com/laurent22/joplin/commit/e797ebb864fbf429a49b6d20e5779d0c9aa6c4d5 web
- https://github.com/laurent22/joplin package
- https://github.com/laurent22/joplin/releases/tag/v2.9.1 web
- https://github.com/ly1g3/Joplin-CVE-2022-35131 web
- http://joplin.com web