GitHub Advisoryadvisory · Packagist

GHSA-ww3w-592j-5qrw SimpleSAMLphp Incorrect IV generation for encryption

MEDIUM Published 2022-05-17 Modified 2024-04-25 Official page ↗
Aliases
CVE-2017-12871
Ecosystem
Packagist
Packages
simplesamlphp/simplesamlphp
Severity
Moderate
CVSS vector
CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
Weaknesses
CWE-326
Reviewed
2024-04-25

Affected packages

• Packagist simplesamlphp/simplesamlphp: >= 1.14.0, < 1.14.12 → fixed in 1.14.12

Description

The aesEncrypt method in `lib/SimpleSAML/Utils/Crypto.php` in SimpleSAMLphp 1.14.x through 1.14.11 makes it easier for context-dependent attackers to bypass the encryption protection mechanism by leveraging use of the first 16 bytes of the secret key as the initialization vector (IV).

Related

Alias · CVE (1)

  • CVE-2017-12871 The aesEncrypt method in lib/SimpleSAML/Utils/Crypto.php in SimpleSAMLphp 1.14.x through 1.14.11 makes it easier for context-dependent… vulnerability

Weakness · CWE (1)

  • CWE-326 Inadequate Encryption Strength weakness

References