GitHub Advisoryadvisory · Maven

GHSA-ww97-9w65-2crx Improper Input Validation in Apache Solr

HIGH Published 2020-02-12 Modified 2025-10-22 Official page ↗
Aliases
CVE-2019-17558
Ecosystem
Maven
Packages
org.apache.solr:solr-core
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H/E:H
Weaknesses
CWE-20, CWE-74, CWE-94
Reviewed
2020-02-11

Affected packages

• Maven org.apache.solr:solr-core: >= 5.0.0, < 8.4.0 → fixed in 8.4.0 • Maven org.apache.solr:solr-core: >= 6.0.0, < 8.4.0 → fixed in 8.4.0 • Maven org.apache.solr:solr-core: >= 7.0.0, < 8.4.0 → fixed in 8.4.0 • Maven org.apache.solr:solr-core: >= 8.0.0, < 8.4.0 → fixed in 8.4.0

Description

Apache Solr 5.0.0 to Apache Solr 8.3.1 are vulnerable to a Remote Code Execution through the VelocityResponseWriter. A Velocity template can be provided through Velocity templates in a configset `velocity/` directory or as a parameter. A user defined configset could contain renderable, potentially malicious, templates. Parameter provided templates are disabled by default, but can be enabled by setting `params.resource.loader.enabled` by defining a response writer with that setting set to `true`. Defining a response writer requires configuration API access. Solr 8.4 removed the params resource loader entirely, and only enables the configset-provided template rendering when the configset is `trusted` (has been uploaded by an authenticated user).

Related

Alias · CVE (1)

  • CVE-2019-17558 Apache Solr 5.0.0 to Apache Solr 8.3.1 are vulnerable to a Remote Code Execution through the VelocityResponseWriter. vulnerability

Weakness · CWE (3)

  • CWE-20 Improper Input Validation weakness
  • CWE-74 Improper Neutralization of Special Elements in Output Used by a Downstream Component weakness
  • CWE-94 Improper Control of Generation of Code weakness

References