GitHub Advisoryadvisory · Go
GHSA-wwhj-pw6h-f8hw Mattermost Incorrect Authorization vulnerability
LOW
Official page ↗
- Aliases
- CVE-2025-2424
- Ecosystem
- Go
- Packages
- github.com/mattermost/mattermost/server/v8
- Severity
- Low
- CVSS vector
- CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:N/A:N
- Weaknesses
- CWE-863
- Reviewed
- 2025-04-14
Affected packages
• Go github.com/mattermost/mattermost/server/v8: >= 10.5.0, < 10.5.2 → fixed in 10.5.2
• Go github.com/mattermost/mattermost/server/v8: >= 9.11.0, < 9.11.10 → fixed in 9.11.10
• Go github.com/mattermost/mattermost/server/v8: < 8.0.0-20250213231113-68c11e9ecb71 → fixed in 8.0.0-20250213231113-68c11e9ecb71
Description
Mattermost versions 10.5.x <= 10.5.1, 9.11.x <= 9.11.9 fail to check if a file has been deleted when creating a bookmark which allows an attacker who knows the IDs of deleted files to obtain metadata of the files via bookmark creation.
Related
Alias · CVE (1)
- CVE-2025-2424 Mattermost versions 10.5.x <= 10.5.1, 9.11.x <= 9.11.9 fail to check if a file has been deleted when creating a bookmark which allows an… vulnerability
Weakness · CWE (1)
- CWE-863 Incorrect Authorization weakness