GitHub Advisoryadvisory · Maven

GHSA-wwww-xvm2-62w7 Jenkins Delphix Plugin vulnerable to exposure of system-scoped credentials

MEDIUM Published 2023-08-16 Modified 2023-08-16 Official page ↗
Aliases
CVE-2023-40345
Ecosystem
Maven
Packages
org.jenkins-ci.plugins:delphix
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
Weaknesses
CWE-522
Reviewed
2023-08-16

Affected packages

• Maven org.jenkins-ci.plugins:delphix: < 3.0.3 → fixed in 3.0.3

Description

Jenkins Delphix Plugin 3.0.2 and earlier does not set the appropriate context for credentials lookup, allowing the use of System-scoped credentials otherwise reserved for the global configuration. This allows attackers with Overall/Read permission to access and capture credentials they are not entitled to. Delphix Plugin 3.0.3 defines the appropriate context for credentials lookup.

Related

Alias · CVE (1)

  • CVE-2023-40345 Jenkins Delphix Plugin 3.0.2 and earlier does not set the appropriate context for credentials lookup, allowing attackers with Overall/Read… vulnerability

Weakness · CWE (1)

  • CWE-522 Insufficiently Protected Credentials weakness

References