GitHub Advisoryadvisory · crates.io
GHSA-wwx5-gpgr-vxr7 ismp-grandpa crate accepted incorrect signatures
CRITICAL
Official page ↗
- Aliases
- CVE-2025-24800
- Ecosystem
- crates.io
- Packages
- ismp-grandpa, grandpa-verifier-primitives, grandpa-verifier
- Severity
- Critical
- CVSS vector
- CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N
- Weaknesses
- CWE-347
- Reviewed
- 2025-01-28
Affected packages
• crates.io ismp-grandpa: < 15.0.1 → fixed in 15.0.1
• crates.io grandpa-verifier-primitives: < 0.1.2 → fixed in 0.1.2
• crates.io grandpa-verifier: < 0.1.2 → fixed in 0.1.2
Description
A critical vulnerability was discovered in the `ismp-grandpa` crate, that allowed a malicious prover easily convince the verifier of the finality of arbitrary headers.
Description
The vulnerability manifests as a verifer that only accepts incorrect signatures of Grandpa precommits and was introduced in this specific commit. Perhaps due to unfamiliarity with core substrate APIs. The `if` statement should have included a negation check, similar to the previous code, but this was omitted. Causing the verifier to only accept invalid signatures.
This vulnerability remained undetected even with integration tests, as the prover was also misconfigured to initialize the Grandpa verifier with the incorrect authority `set_id`. This causes verification of honest precommit signatures to fail as the message is now malformed, but the verifier indeed only accepts signatures or messages that fail the verification check.
But even more devastatingly, the verifier will also accept malicious GRANDPA signatures for any precommit message.
This vulnerability has been fixed in this commit and a patch release has been published.
Impact
This could be used to steal funds or compromise other kinds of cross-chain applications.
Patches
This vulnerability has been fixed in the latest version of `ismp-granpda` `v15.0.1`
Recommendations
Users who rely on the compromised versions must upgrade immediately, as all vulnerable versions of the crate has been yanked.
Related
Alias · CVE (1)
- CVE-2025-24800 Hyperbridge is a hyper-scalable coprocessor for verifiable, cross-chain interoperability. vulnerability
Weakness · CWE (1)
- CWE-347 Improper Verification of Cryptographic Signature weakness
References
- https://github.com/polytope-labs/hyperbridge/security/advisories/GHSA-wwx5-gpgr-vxr7 web
- https://nvd.nist.gov/vuln/detail/CVE-2025-24800 advisory
- https://github.com/polytope-labs/hyperbridge/pull/372/commits/f0e85db718f5165b06585a49b14a66f8ad643aea web
- https://github.com/polytope-labs/ismp-substrate/pull/64/commits/04d5be207b082eb61d586d52e1685e2e060347e6#diff-4aedbca82d26bebc03f274e23fd5697c3346ffff54405c87af9018f3aef708b2R1-R160 web
- https://github.com/polytope-labs/ismp-substrate/pull/64/commits/5ca3351a19151f1a439c30d5cbdbfdc72a11f1a8#diff-3835cc24fb2011b3e8246036059acd8c2c2a9a869eedf7a210d18edb6543318dL262 web
- https://github.com/polytope-labs/ismp-substrate/pull/64/commits/b26894913b301061b07db61af841ca2586415f08#diff-493a6129d75fe31185e28695a4d2adc1582fe9df12462e380fe994f170fc1e70L159 web
- https://github.com/polytope-labs/hyperbridge package