GitHub Advisoryadvisory · Packagist
GHSA-wx24-vqrg-m6m5 VuFind Server-Side Request Forgery (SSRF) vulnerability
CRITICAL
Official page ↗
- Aliases
- CVE-2024-25738
- Ecosystem
- Packagist
- Packages
- vufind/vufind
- Severity
- Critical
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
- Weaknesses
- CWE-918
- Reviewed
- 2024-05-23
Affected packages
• Packagist vufind/vufind: >= 2.0, < 9.1.1 → fixed in 9.1.1
Description
A Server-Side Request Forgery (SSRF) vulnerability in the /Upgrade/FixConfig route in Open Library Foundation VuFind 2.0 through 9.1 before 9.1.1 allows a remote attacker to overwrite local configuration files to gain access to the administrator panel and achieve Remote Code Execution. A mitigating factor is that it requires the allow_url_include PHP runtime setting to be on, which is off in default installations. It also requires the /Upgrade route to be exposed, which is exposed by default after installing VuFind, and is recommended to be disabled by setting autoConfigure to false in config.ini.
Related
Alias · CVE (1)
- CVE-2024-25738 A Server-Side Request Forgery (SSRF) vulnerability in the /Upgrade/FixConfig route in Open Library Foundation VuFind 2.0 through 9.1 before… vulnerability
Weakness · CWE (1)
- CWE-918 Server-Side Request Forgery weakness