GitHub Advisoryadvisory · Packagist
GHSA-wx87-h539-4775 Moodle Information Disclosure vulnerability
MEDIUM
Official page ↗
- Aliases
- CVE-2021-32473
- Ecosystem
- Packagist
- Packages
- moodle/moodle
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
- Weaknesses
- CWE-200
- Reviewed
- 2024-04-23
Affected packages
• Packagist moodle/moodle: >= 3.5, < 3.5.18 → fixed in 3.5.18
• Packagist moodle/moodle: >= 3.8, < 3.8.9 → fixed in 3.8.9
• Packagist moodle/moodle: >= 3.9, < 3.9.7 → fixed in 3.9.7
• Packagist moodle/moodle: >= 3.10, < 3.10.4 → fixed in 3.10.4
Description
It was possible for a student to view their quiz grade before it had been released, using a quiz web service. Moodle 3.10 to 3.10.3, 3.9 to 3.9.6, 3.8 to 3.8.8, 3.5 to 3.5.17 and earlier unsupported versions are affected
Related
Alias · CVE (1)
- CVE-2021-32473 It was possible for a student to view their quiz grade before it had been released, using a quiz web service. vulnerability
Weakness · CWE (1)
- CWE-200 Exposure of Sensitive Information to an Unauthorized Actor weakness