GitHub Advisoryadvisory · npm

GHSA-wxgh-8gmr-3qh3 terminal-kit Inefficient Regular Expression Complexity vulnerability

HIGH Published 2023-01-07 Modified 2023-01-12 Official page ↗
Aliases
CVE-2021-4306
Ecosystem
npm
Packages
terminal-kit
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weaknesses
CWE-1333
Reviewed
2023-01-12

Affected packages

• npm terminal-kit: < 2.1.8 → fixed in 2.1.8

Description

A vulnerability classified as problematic has been found in cronvel terminal-kit up to 2.1.7. Affected is an unknown function. The manipulation leads to inefficient regular expression complexity. Upgrading to version 2.1.8 can address this issue. The name of the patch is a2e446cc3927b559d0281683feb9b821e83b758c. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-217620.

Related

Alias · CVE (1)

  • CVE-2021-4306 A vulnerability classified as problematic has been found in cronvel terminal-kit up to 2.1.7. vulnerability

Weakness · CWE (1)

  • CWE-1333 Inefficient Regular Expression Complexity weakness

References