GitHub Advisoryadvisory · Maven

GHSA-wxqc-pxw9-g2p8 Spring Framework vulnerable to denial of service

HIGH Published 2023-04-13 Modified 2024-06-10 Official page ↗
Aliases
CVE-2023-20863
Ecosystem
Maven
Packages
org.springframework:spring-expression
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weaknesses
CWE-400, CWE-770, CWE-917
Reviewed
2023-04-17

Affected packages

• Maven org.springframework:spring-expression: >= 6.0.0, < 6.0.8 → fixed in 6.0.8 • Maven org.springframework:spring-expression: >= 5.3.0, < 5.3.27 → fixed in 5.3.27 • Maven org.springframework:spring-expression: < 5.2.24.RELEASE → fixed in 5.2.24.RELEASE

Description

In Spring Framework versions prior to 5.2.24.release+ , 5.3.27+ and 6.0.8+ , it is possible for a user to provide a specially crafted Spring Expression Language (SpEL) expression that may cause a denial-of-service (DoS) condition.

Related

Alias · CVE (1)

  • CVE-2023-20863 In spring framework versions prior to 5.2.24 release+ ,5.3.27+ and 6.0.8+ , it is possible for a user to provide a specially crafted SpEL… vulnerability

Weakness · CWE (3)

  • CWE-400 Uncontrolled Resource Consumption weakness
  • CWE-770 Allocation of Resources Without Limits or Throttling weakness
  • CWE-917 Improper Neutralization of Special Elements used in an Expression Language Statement weakness

References